Файл конфигурации 1С

Для загрузки конфигурации из файла нужно запустить 1С в режиме Конфигуратор. Нажмите на ярлык 1С: Предприятия и в окне запуска нажмите Конфигуратор.

После этого запустится Конфигуратор 1С.

Загрузка конфигурации из файла выполнятся в меню Конфигурация. Перед загрузкой конфигурации нужно завершить сеансы всех пользователей и предварительно нужно выполнить некоторые действия.

1. Проверьте, что конфигурация открыта (в левой части должно отображаться дерево конфигурации как на скриншоте).

Если конфигурация не отображается, нужно в меню Конфигурация нажать на кнопку Открыть конфигурацию.

2. Конфигурация базы 1С должна быть разброкирована и доступна для изменений, иначе загрузка будет недоступна. Для того этого нужно выполнить следующие действия.

Перейти в меню Конфигурация – Поддержка – Настройка поддержки…

В открывшемся окне нажать кнопку Включить возможность изменения.

В окне Настройка правил поддержки выбрать дважды Объект поставщика снят с поддержки и нажать «ОК”.

После этого нажать на кнопку Снять с поддержки.

На все вопросы программы нажимать утвердительно.

Кнопка Включить возможность изменения может быть недоступна (уже включена ранее) и доступна только кнопка Снять с поддержки. В этом случае нужно сразу нажать на нее.

Таким образом, конфигурация базы 1С разблокирована и доступна для изменений. Можно перейти к загрузке конфигурации 1С из файла.

Перед выполнение загрузки сохраните изменения, нажмите Ctrl+S или Файл – Сохранить.

4. Для загрузки конфигурации из файла нужно перейти в меню Конфигурация и нажать на кнопку Загрузить конфигурацию из файла.

Выбрать файл конфигурации (у него расширение .cf), нажать на кнопку Открыть и Да.

В базу 1С будет загружена конфигурация из файла. После завершения загрузки нужно сохранить конфигурацию (Ctrl+S или нажать кнопку дискеты как на скриншоте) и обновить базу данных по кнопке бочонка (F7).

При обновлении базы появится окно как на скриншоте, в которой нужно нажать Принять.

Таким образом конфигурация базы 1С обновлена, можно запускать сеансы пользователей и работать с базой.

Как сохранить рабочую конфигурацию из конфигуратора знают все, но это не всегда удобно. Мне понадобилось сохранять рабочую конфигурацию и тут-же этот файл обрабатывать. Предлагаю простую процедуру:

Код 1C v 8.х // функция сохраняет рабочую конфигурацию в файл, в случае успеха возвращает Истина
// параметры:
// Логин — имя пользователя с правами на админисирирование БД
// Пароль — строка пароля
// ИмяФайла — полное имя файла для сохранения конфигурации, не обязательно.
// по умолчанию использует каталог временных файлов и имя 1Cv8.cf
функция СохранитьТекущуюКонфигурацию (Логин, Пароль, ИмяФайла=»») экспорт
результат = Ложь;
Если ИмяФайла = «» Тогда
ИмяФайла = КаталогВременныхФайлов() + «1Cv8.cf»;
КонецЕсли;
СтрокаБазы = СтрокаСоединенияИнформационнойБазы();
Если Лев(СтрокаБазы, 5) = «File=» Тогда
// файловый вариант
СтрокаБазы = Сред(СтрокаБазы, 6, СтрДлина(СтрокаБазы) — 6);
Иначе
// серверный вариант пока не готов…
// может кто допишет?
возврат Ложь;
КонецЕсли;
ВыбФайл = Новый Файл(ИмяФайла);
Если ВыбФайл.Существует() Тогда
Сигнатура = Строка(ВыбФайл.Размер()) + Строка(ВыбФайл.ПолучитьВремяИзменения());
Иначе
Сигнатура = «»;
КонецЕсли;
СтрокаЗапуска = «»»» + КаталогПрограммы() + «1cv8.exe»» CONFIG /F » + СтрокаБазы
+ ?(Логин = «», «», » /N » + Логин)

+ ?(Пароль = «», «», » /P » + Пароль) + » /DumpDBCfg «»» + ИмяФайла + «»»»;
//
// КомандаСистемы (СтрокаЗапуска); не работает!!!!! из-за кавычек в параметрах
// приходиться идти кругом…
// зато можно избежать черного окошка
//
WshShell = Новый COMОбъект(«WScript.Shell»);
WshShell.Run(СтрокаЗапуска, 0, Истина);
ВыбФайл = Новый Файл(ИмяФайла);
Если ВыбФайл.Существует() Тогда
НоваяСигнатура = Строка(ВыбФайл.Размер()) + Строка(ВыбФайл.ПолучитьВремяИзменения());
Если Сигнатура <> НоваяСигнатура Тогда
Результат = Истина;
КонецЕсли;
КонецЕсли;
Возврат Результат;
КонецФункции
ну и пример использования (работает если нет пароля):
Код 1C v 8.х Функция ЗаписатьКонфигурациюВФайл(ИмяФайла=»»)
Результат = Ложь;
ВыбФайл = Новый Файл(ИмяФайла);
Если ВыбФайл.Существует() Тогда
Если ВыбФайл.ЭтоКаталог() Тогда
ИмяФайла=»»;
КонецЕсли;
КонецЕсли;
Попытка
Массив = ПользователиИнформационнойБазы.ПолучитьПользователей();
Логин = «»;
Пароль = «»;
Если Массив.Количество() > 0 тогда
Пользователь = ПользователиИнформационнойБазы.ТекущийПользователь();
Логин = Пользователь.Имя;
Если Пользователь.ПарольУстановлен Тогда
// тут нужно получить пароль, лучше интерактивно
// но лично мне это совсем не нужно
Предупреждение(«У Вас установлен пароль, этот режим сейчас не доступен»);
Возврат Ложь;
КонецЕсли
КонецЕсли;
Результат = СохранитьТекущуюКонфигурацию(Логин, Пароль, ИмяФайла);
Если не Результат Тогда
Предупреждение(«Конфигурация не сохранена»);
Иначе
Сообщить(«Конфигурация успешно сохранена в файл: » + ИмяФайла);
КонецЕсли;
Исключение
Предупреждение(«У Вас не достаточно прав для сохранения конфигурации»);
Возврат Ложь;
КонецПопытки;
Возврат Результат;
КонецФункции

Механизм выгрузки и загрузки конфигурации в файлы позволяет осуществлять полную выгрузку/загрузку конфигурации (модулей, макетов, прав доступа, справочной информации и картинок) в указанный каталог в виде набора файлов:

Конфигурация выгружается в набор файлов разного типа: xml, html, bin, bsl и так другие. Тип файла соответствует содержимому. Например, структура объекта конфигурации Справочник выгружается в файл xml, а модуль объекта этого справочника — в текстовый файл с расширением bsl..

Выгрузка осуществляется в иерархический формат, который позволяет избавиться от очень длинных имён файлов.

Благодаря использованию XML можно выполнять обработку и анализ конфигурации как программными средствами, так и вручную.

Поддерживается инкрементальная выгрузка. Она сокращает время выгрузки за счёт того, что выгружаются только те файлы, которые были изменены с момента предыдущей выгрузки. Аналогичным образом выполняется и инкрементальная загрузка.

Выгрузка и загрузка файлов конфигурации также возможна при запуске конфигуратора в пакетном режиме или в режиме агента.

Информационная база 1С содержи данные и конфигурацию. В конфигурации описывается структура, визуализация, методы обработки данных. Конфигурацию можно выгружать и загружать в информационную базу через конфигуратор. Соответственно, при загрузке конфигурации, если структура данных в базе не соответствует загружаемой конфигурации, то данные будут утеряны. Поэтому при любых изменениях рекомендуется делать бэкап информационной базы. Если требуется выгрузить данные и конфигурацию, то необходимо выполнить выгрузку информационной базы.

Выгрузка загрузка конфигурационного файла

Для работы с файлами cf потребуется запуск информационной базы в режиме 1С Конфигуратор. Конфигурационный файл выгружается с расширением (*.cf). Как правило, фалы выгружаются не большого размера. Важной особенности файлов cf является, то что они НЕ СОДЕРЖАТ ДАННЫХ. При загрузке конфигурации, текущая конфигурация будет полностью заменена на загружаемую. Для того чтобы выгрузить файл, необходимо в главном меню перейти: Конфигурация->Сохранить конфигурацию в файл. Для того чтобы загрузить конфигурацию нужно перейти: Конфигурация->Загрузить конфигурацию из файла.

Add a Comment

Ваш адрес email не будет опубликован. Обязательные поля помечены *