Мобильный 1С

Мобильная платформа «1С:Предприятия 8» — это название технологии, которая позволяет разрабатывать решения, работающие на смартфонах и планшетах Google Android или Apple iOS. Важным преимуществом платформы «1С» является то, что решения разрабатываются в одном варианте для обоих мобильных операционных систем и затем просто экспортируются для Android и для iOS без какой-либо дополнительной модификации и написания платформенно-зависимого программного кода.

Подробнее о мобильной платформе на портале Мобильный бизнес

На мобильное устройство устанавливается сразу и платформа «1С:Предприятие» и сама информационная база (конфигурация, в терминах «1С»). Информационная база на устройстве содержит вариант файловой базы данных (для хранения различных данных, с которыми работает или будет работать пользователь) и само приложение (программный байт-код, который исполняющийся на планшете или смартфоне).

Пример мобильного клиента для СЭД «Корпоративный документооборот» созданный на мобильной платформе «1С:Предприятие 8.3»

Платформой поддерживается скачивание и развертывание приложений пользователями на их устройствах из магазинов App Store или Google Play. Дистрибутив при этом содержит все компоненты, необходимые для начала работы.

На базе мобильной платформы «1С» могут быть созданы различные решения, но основным вариантом решений являются мобильные off-line клиенты для учетных систем. Такие решения предназначены для поддержки мобильных пользователей в удаленных рабочих местах. Обмен данными при этом производится посредством регулярной синхронизации с центральной базой данных. Обмен данными возможен посредством следующих механизмов:

  • Web-сервисы
  • Файловый обмен
  • Электронная почта
  • и другие механизмы
    Альтернативным вариантом может являться работа в онлайне в режиме веб-клиента.

Разработанное мобильное приложение является отдельным, законченным программным продуктом и может обмениваться данными сразу с несколькими центральными базами данных. Например в одном мобильном приложении можно реализовать доступ и работу с документами из бухгалтерской базы данных и задачами из системы документооборота предприятия.

  • Платформа «1С:Предприятие 8.3» является универсальным средством разработки как обычных десктопных приложений, так и мобильных. Основные механизмы разработки приложений обоих типов идентичны, тем не менее, при разработке приложений для Android и iOS на данный день существует ряд ограничений:
    • Рабочий стол содержит только одну форму
    • Используются не все классы объектов конфигурации
    • Не используется механизм распределенных информационных баз
    • Используется ограниченный набор элементов формы
    • Не поддерживается пошаговая отладка
    • Не используется язык запросов и система компоновки данных;и ряд других отличий

    Признаком использования, разрабатываемой мобильной конфигурации является свойство конфигурации «Назначение использования» оно может быть установлено в значение «Персональный компьютер», в значение «Мобильное устройство», а также возможно сочетание обоих назначений в одной конфигурации.. Если установить значение «Мобильное устройство», то система автоматически скроет возможности, недоступные для мобильной платформы, а все рабочие инструменты, такие как проверка синтаксиса, проверка конфигурации и другие будут настроены на работу именно с тем контекстом встроенного языка, который доступен в мобильной платформе.

    Экспорт приложений в Android и iOS на практике достаточно прост. Что бы создать приложение, готовое к использованию на мобильном устройстве необходимо выполнить следующие действия:

    • В режиме «Конфигуратор» в меню «Мобильное приложение» выбрать пункт «Записать в файл». При этом будет сформирован специальный XML-файл со структурой метаданных приложения
    • В пользовательском режиме открыть обработку «Помощник создания мобильного приложения» и из полученного ранее XML-файла, а также комплекта дистрибутива мобильной платформы и дополнительных файлов собрать дистрибутив мобильного приложения для операционной системы Android и/или iOS
    • Полученный дистрибутив для операционной системы Android можно сразу загрузить в магазин приложений Google Play
    • Полученный дистрибутив для iOS перед загрузкой в App Store необходимо дополнительно собрать с помощью программы Xcode на компьютере с операционной системой Mac OS X.

    Доступны русский и английский языки платформы.

    На данный день нами выпущена альфа-версия мобильного клиента для нашей системы документооборота. Получить дополнительную информацию о мобильном клиенте документооборота и посмотреть некоторые реальные изображения приложения можно здесь:

    Мобильный клиент на базе «1С:Предприятие 8.3»

    Дополнительные матриалы: Установка и подключение мобильного клиента

Интерактивная инструкция по работе с приложением:

Функциональные возможности 1С:УНФ для мобильных устройств:
☆ Быстрый и удобный оперативный учет заказов.
☆ Розница: возможность пробития чеков из заказа покупателя и в отдельном интерфейсе кассира. Поддержка торгового оборудования: сканеры штрих-кодов, эквайринговые терминалы, ККТ-онлайн с поддержкой 54-ФЗ.
☆ Ведение базы покупателей и поставщиков с их телефонами и электронными адресами.
☆ Учет долгов покупателей и поставщикам.
☆ Учет товаров: остатки на складе, закупочная цена, цена продажи, фотографии товаров.
☆ Производство: выпуск продукции и калькуляция себестоимости по учетным ценам.
☆ Использование камеры устройства, в качестве сканера штрих-кодов.
☆ Учет оплаты заказов, отчет по движению денежных средств.
☆ Расчет валовой прибыли.
☆ Отправка счетов на оплату по e-mail и SMS.
☆ Печать отчетов и документов на принтерах WiFI и Bluetooth.
Помимо автономной работы это приложение можно использовать совместно с программой «1С:Управление нашей фирмой» для ПК или в «облаке»:
☆ настраивается обмен между приложениями информацией о новых заказах, оплате заказов, остатках товаров;
☆ поддерживается работа как с одного мобильного устройства, так и с нескольких смартфонов или планшетов разных платформ.
Приложение «1С:Управление нашей фирмой для мобильной работы» разработано на мобильной платформе «1С:Предприятие 8».
Для оперативного решения проблем, возникающих при работе с мобильным приложением пишите на v8@1c.ru

Создание конфигурации для мобильного приложения

Создадим новую «пустую» базу. Дадим имя конфигурации «Pomodoro». Обязательно укажем свойство «назначение использования» — «Мобильное приложение»

а в свойстве «Требуемые разрешения мобильного приложения» установим флажки «Локальные уведомления» и «Встроенные покупки»

Создадим регистр сведений, в котором будет храниться информация о «полученных» помидорах (количество законченных отрезков времени, в течение которого пользователь продуктивно работал)

Таймер средствами 1С

В обработке можно запустить таймер и дождаться окончания его работы, либо остановить таймер. В первом случае пользователь получит PUSH-уведомление о том, что он заработал очередной помидор (запись в регистр сведений «Помидоры»), во втором случае PUSH-уведомление о том, что помидор не получен (запись в регистр не производится).

Также на форме в процессе работы таймера будет показан индикатор, выполняться обратный отсчет и показываться текущее время и время окончания работы таймера

Создадим обработку Таймер и основную форму

Для формы создадим команду «Запустить таймер», обработчик действия (нажатие):

&НаКлиенте Процедура ЗапуститьТаймер(Команда) Элементы.ФормаОстановитьТаймер.Доступность = Истина; Элементы.ФормаЗапуститьТаймер.Доступность = Ложь; КоличествоМинут = 25; МаксимальноеЗначение = КоличествоМинут * 60; Элементы.Индикатор.МинимальноеЗначение = 0; Элементы.Индикатор.МаксимальноеЗначение = ЭтотОбъект.МаксимальноеЗначение; ЭтотОбъект.Начало = ТекущаяДата(); ЭтотОбъект.Конец = Начало + МаксимальноеЗначение; ЭтотОбъект.ТекущаяДата = ТекущаяДата(); ПодключитьОбработчикОжидания(«ВыполнитьОтсчет»,1); КонецПроцедуры И команду «ОстановитьТаймер», обработчик действия (нажатие): &НаКлиенте Процедура ОстановитьТаймер(Команда) Элементы.ФормаОстановитьТаймер.Доступность = Ложь; Элементы.ФормаЗапуститьТаймер.Доступность = Истина; ОтключитьОбработчикОжидания(«ВыполнитьОтсчет»); #Если МобильноеПриложениеКлиент Тогда Уведомление = Новый ДоставляемоеУведомление; Уведомление.Заголовок = «К сожалению, Вы не получите помидор.»; Уведомление.Текст = «К сожалению, Вы не получите помидор.»; Уведомление.ЗвуковоеОповещение = ЗвуковоеОповещение.ПоУмолчанию; ДоставляемыеУведомления.ДобавитьЛокальноеУведомление(Уведомление); ДоставляемыеУведомления.ПодключитьОбработчикУведомлений(«ПриПолученииУведомления»); #Иначе Сигнал(); Сообщение = Новый СообщениеПользователю; Сообщение.Текст = «К сожалению, Вы не получите помидор.»; Сообщение.Сообщить(); #КонецЕсли КонецПроцедуры

В этих процедурах подключается (либо отключается) обработчик ожидания «ВыполнитьОтсчет», а также выполняется работа с PUSH-уведомлениями

Уведомление = Новый ДоставляемоеУведомление;

Код процедуры обработчика ожидания ВыполнитьОтсчет»:

&НаКлиенте Процедура ВыполнитьОтсчет() Если ЭтотОбъект.ТекущаяДата <= ЭтотОбъект.Конец Тогда ЭтотОбъект.Индикатор = ЭтотОбъект.ТекущаяДата — ЭтотОбъект.Начало; ЭтотОбъект.ТекущаяДата = ТекущаяДата(); ОсталосьАбсолютно = ЭтотОбъект.МаксимальноеЗначение — ЭтотОбъект.Индикатор; ЭтотОбъект.Осталось = «» + Формат(Цел(ОсталосьАбсолютно/60), «ЧЦ=2; ЧН=00; ЧВН=») + «:» + Формат(ОсталосьАбсолютно — Цел(ОсталосьАбсолютно/60)*60, «ЧЦ=2; ЧН=00; ЧВН=»); ЭтотОбъект.ОбновитьОтображениеДанных(); Иначе ЭтотОбъект.Индикатор = МаксимальноеЗначение; ЭтотОбъект.ТекущаяДата = ЭтотОбъект.Конец; ЭтотОбъект.Осталось = Формат(0, «ЧЦ=2; ЧН=00; ЧВН=») + «:» + Формат(0, «ЧЦ=2; ЧН=00; ЧВН=»); #Если МобильноеПриложениеКлиент Тогда Уведомление = Новый ДоставляемоеУведомление; Уведомление.Заголовок = «Вы собрали еще один помидор.»; Уведомление.Текст = «Вы собрали еще один помидор. Отдохните » + ПолучитьКоличествоМинутОтдыхаНаСервере(ЭтотОбъект.ТекущаяДата) + » минут.»; Уведомление.ЗвуковоеОповещение = ЗвуковоеОповещение.ПоУмолчанию; ДоставляемыеУведомления.ДобавитьЛокальноеУведомление(Уведомление); ДоставляемыеУведомления.ПодключитьОбработчикУведомлений(«ПриПолученииУведомления»); #Иначе Сигнал(); Сообщение = Новый СообщениеПользователю; Сообщение.Текст = «Вы собрали еще один помидор. Отдохните » + ПолучитьКоличествоМинутОтдыхаНаСервере(ЭтотОбъект.ТекущаяДата) + » минут.»; Сообщение.Сообщить(); #КонецЕсли Элементы.ФормаОстановитьТаймер.Доступность = Ложь; Элементы.ФормаЗапуститьТаймер.Доступность = Истина; ОтключитьОбработчикОжидания(«ВыполнитьОтсчет»); КонецЕсли; КонецПроцедуры &НаСервере Функция ПолучитьКоличествоМинутОтдыхаНаСервере(Дата) //Занесем запись в регистр РС = РегистрыСведений.Помидоры.СоздатьМенеджерЗаписи(); РС.Активность = Истина; РС.Количество = 1; РС.Период = Дата; РС.Записать(); //по умолчанию 5 минут //после каждого 4-го помидора в день — 15 минут Запрос = Новый Запрос; Запрос.Текст = «ВЫБРАТЬ | СУММА(Помидоры.Количество) КАК Количество |ИЗ | РегистрСведений.Помидоры КАК Помидоры |ГДЕ | Помидоры.Период МЕЖДУ НАЧАЛОПЕРИОДА(&Период, ДЕНЬ) И КОНЕЦПЕРИОДА(&Период, ДЕНЬ)»; Запрос.УстановитьПараметр(«Период», Дата); Результат = Запрос.Выполнить().Выгрузить(); Если Результат.Количество() > 0 Тогда Сумма = Результат.Количество; Если Цел(Сумма/4) = (Сумма/4) Тогда Возврат 15; КонецЕсли; КонецЕсли; Возврат 5; КонецФункции

Вывод PUSH-уведомлений реализуется так:

&НаКлиенте Процедура ПриПолученииУведомления(Уведомление, Локальное, Показано) Экспорт Если Локальное Тогда Сообщить(Уведомление.Текст); КонецЕсли; КонецПроцедуры

В коде выполняется управление доступностью кнопок запуска и остановки таймера в зависимости от его состояния (запущен таймер, либо остановлен) – осталось установить первоначальную видимость этих кнопок при открытии формы:

&НаКлиенте Процедура ПриОткрытии(Отказ) Элементы.ФормаОстановитьТаймер.Доступность = Ложь; Элементы.ФормаЗапуститьТаймер.Доступность = Истина; КонецПроцедуры

Статистика – диаграмма

Создадим обработку Статистика и основную форму

Полную реализацию Вы можете посмотреть во вложенном файле конфигурации. Сейчас рассмотрим программный вывод анимированной диаграммы на форму

Инициализация:

&НаСервере Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка) Для Каждого Стр Из ТипДиаграммы Цикл Элементы.ВидДиаграммы.СписокВыбора.Добавить(Стр, Стр, , );//Статистика Элементы.ВидДиаграммыПродуктивность.СписокВыбора.Добавить(Стр, Стр, , );//Продуктивность КонецЦикла; //Статистика Период.Вариант = ВариантСтандартногоПериода.ЭтаНеделя; Периодичность = «ДЕНЬ»; ВидДиаграммы = ТипДиаграммы.Изометрическая; ОбновитьДиаграмму(); //Продуктивность ПериодПродуктивность.Вариант = ВариантСтандартногоПериода.ЭтаНеделя; ПериодичностьПродуктивность = «ДЕНЬНЕДЕЛИ»; ВидДиаграммыПродуктивность = ТипДиаграммы.Изометрическая; ОбновитьДиаграммуПродуктивность(); КонецПроцедуры

Вывод диаграммы:

&НаКлиенте Процедура ВидДиаграммыПриИзменении(Элемент) ОбновитьДиаграмму(); КонецПроцедуры &НаСервере Процедура ОбновитьДиаграмму() // Очистить диаграмму, возможно ранее в нее уже выводились данные. Диаграмма.Очистить(); //Диаграмма.ОбластьЗаголовка.Текст = «Статистика собранных помидоров»; //Диаграмма.МаксимумСерий = МаксимумСерий.Ограничено; //Диаграмма.МаксимумСерийКоличество = 7; // Запретить обновление диаграммы на время вывода данных. Диаграмма.Обновление = Ложь; //Диаграмма.Анимация = АнимацияДиаграммы.Использовать; Диаграмма.ТипДиаграммы = ?(ВидДиаграммы <> Неопределено, ВидДиаграммы, ТипДиаграммы.ГистограммаОбъемная);//ТипДиаграммы.ГистограммаОбъемная; // Установить единственную точку. Диаграмма.КоличествоТочек = 1; Диаграмма.Точки.Текст = «Количество»; Запрос = Новый Запрос; Запрос.Текст = «ВЫБРАТЬ | НАЧАЛОПЕРИОДА(Помидоры.Период, ДЕНЬ) КАК Период, | СУММА(Помидоры.Количество) КАК Количество |ИЗ | РегистрСведений.Помидоры КАК Помидоры |ГДЕ | Помидоры.Период МЕЖДУ &НачалоПериода И &КонецПериода | |СГРУППИРОВАТЬ ПО | НАЧАЛОПЕРИОДА(Помидоры.Период, ДЕНЬ) | |УПОРЯДОЧИТЬ ПО | Период»; Запрос.Текст = СтрЗаменить(Запрос.Текст,»ДЕНЬ» , Периодичность); Запрос.УстановитьПараметр(«НачалоПериода», Период.ДатаНачала); Запрос.УстановитьПараметр(«КонецПериода», Период.ДатаОкончания); Результат = Запрос.Выполнить(); Выборка = Результат.Выбрать(); ФорматнаяСтрока = «ДФ=dd.MM.yyyy»; Если Периодичность = «МЕСЯЦ» Тогда ФорматнаяСтрока = «ДФ=MMMM.yyyy»; ИначеЕсли Периодичность = «ГОД» Тогда ФорматнаяСтрока = «ДФ=yyyy»; КонецЕсли; Пока Выборка.Следующий() Цикл КоличествоСерий = Диаграмма.Серии.Количество(); Диаграмма.КоличествоСерий = КоличествоСерий + 1; Диаграмма.Серии.Текст = Формат(Выборка.Период, ФорматнаяСтрока); Диаграмма.УстановитьЗначение(0, КоличествоСерий, Выборка.Количество); КонецЦикла; Диаграмма.ОбластьЛегенды.Прокрутка = Истина; КонецПроцедуры

Управление рекламой

Для управления рекламой используется свойство глобального контекста «ОтображениеРекламы»

Реклама будет выводиться в виде рекламного баннера вверху, либо внизу (свойство «ОтображениеРекламногоБаннера») окна приложения:

Включение показа рекламного баннера реализуем в Модуле управляемого приложения в процедуре ПриНачалеРаботыСистемы():

Процедура ПриНачалеРаботыСистемы() Если СлужебныйВызовСервера.ПоказыватьРекламу() Тогда #Если МобильноеПриложениеКлиент ИЛИ МобильноеПриложениеСервер Тогда ОР = ОтображениеРекламы; ОР.УстановитьИспользование(Истина); ОР.SetAdBannerID(«ca-app-pub-1356011826682846/4780285411»); ОР.УстановитьОтображениеРекламногоБаннера(ОтображениеРекламногоБаннера.Верх); #КонецЕсли КонецЕсли; КонецПроцедуры

Управление покупками

Управление покупками выполняется в следующей последовательности:

ВП = ВстроенныеПокупки; ВП.НачатьПриобретение(); ВП.ИзрасходоватьПокупку(); ОплатаПроизведена = ВП.НачатьПриобретение();

Мобильная бухгалтерия теперь доступна пользователям облачных решений 1С:БизнесСтарт. Все самые важные функции теперь и на экране вашего мобильного! Бесплатное приложение «Мобильная бухгалтерия» доступно в Google Play и App Store.
Бухгалтерия на экране смартфона теперь доступна для пользователей облачных решений 1С:БизнесСтарт в бесплатном приложении «Мобильная бухгалтерия». Приложение «Мобильная бухгалтерия» подходит предпринимателям на УСН (доходы, доходы минус расходы), ЕНВД и патенте, и организациям на УСН (6% и 15%), ЕНВД и общем режиме. В «Мобильной бухгалтерии» вы можете рассчитать налоги, подготовить и отправить платежи в банк, заполнить декларации, отправить счёт (со своей печатью, подписью и логотипом), накладную или акт клиенту, а также получать напоминания о сроках уплаты налогов и подачи деклараций, чтобы ни о чём не забыть.
Помимо этого «Мобильная бухгалтерия» позволяет вам подготовить Книгу учёта доходов и расходов, подготовить отчётность по сотрудникам, товарные чеки, вести учёт денег, расчётов с покупателями и остатков товаров, обеспечивает интеграцию с сервисами 1С:БизнесСтарт и 1С-Отчётность, интеграцию с банками, актуальные сведения о налоговой, резервное копирование и многое другое (некоторые функции доступны только пользователям с подпиской на сервис 1С:БизнесСтарт, либо за дополнительную плату). Вы можете скачать приложение «Мобильная бухгалтерия» в Google Play, App Store, или отсканировав QR-код.

Мобильная платформа 1С:Предприятия – это набор инструментов и технологий для быстрой разработки приложений под мобильные ОС iOS, Android, Windows Phone / 8.1 / 10, с использованием тех же сред разработки (Конфигуратор или 1С:Entrprise Development Tools) и тех же методик разработки, что используются для «обычных» приложений 1С. В результате получаются автономные, офлайновые приложения, но с возможностью обмена информацией с внешним миром при помощи широкого спектра средств интеграции, предоставляемого платформой: Web и HTTP-сервисы, е-мейл и т.д. Поскольку протоколы обмена – платформенно-независимые, мобильная платформа 1С, помимо прочего – это средство быстрого создания мобильного фронт-энда для практически любого серверного решения.

Предыстория

Еще во времена «1С:Предприятия» версии 8.0 (и последующих версий) существовал программный продукт «Расширение для карманных компьютеров». Расширение позволяло создавать продукты только для ОС Windows Mobile, Windows CE и т.д. Продукт обладал собственным конфигуратором, и сервером, и поддерживался вплоть до выпуска «1С:Предприятия» версии 8.3. Последняя версия расширения (8.2.9) была выпущена в октябре 2013 года, а полная поддержка прекратилась 1 января 2015 года.

Расширение имело ограниченное применение даже во времена расцвета коммуникаторов на Windows Mobile, а уход таких устройств с мобильного рынка явно не добавил популярности этому программному продукту. Устройства на iOS и Android заняли практически весь рынок мобильных устройств, и стало очевидно, что поддержка этих ОС является одним из ключевых моментов для системы, которая должна эксплуатироваться в современном мобильном мире. Также казалось очевидным, что основной подход существующей платформы «1С:Предприятие» должен использоваться и на мобильных устройствах: прикладной разработчик должен в первую очередь думать о решении прикладных задач, а во вторую — о том, какие возможности используемой ОС ему задействовать для решения этих задач. Другими словами, нужен инструмент, который изолирует прикладного разработчика от особенностей конкретных мобильных ОС и инструмента разработки.

Мобильная платформа

Опираясь на опыт разработки и эксплуатации расширения для карманных компьютеров, было принято решение разработать специализированную систему, которая бы удовлетворяла нескольким требованиям:

  • она должна поддерживать современные популярные мобильные операционные системы и устройства под их управлением. В первую очередь это ОС iOS фирмы Apple и Android компании Google.
  • эта система должна позволять использовать разработанные приложения в стиле, принятом на современных мобильных устройствах. В частности, интерфейс должен опираться на ручное управление (в буквальном смысле этого слова) с использованием сенсорных экранов.
  • система должна обеспечивать единообразный программный интерфейс для реализации различных специфических механизмов, вне зависимости от используемой мобильной ОС.
  • разработчик должен использовать тот же инструмент и те же подходы к разработке, что и при разработке приложений для «обычного» компьютера.
  • прикладной разработчик должен разрабатывать прикладное решение в привычной среде разработки, по возможности используя единый код для настольной и мобильной систем.
  • интерфейс прикладного решения, работающего на мобильном устройстве, должен быть аналогичен для различных платформ и в целом однозначно узнаваем.

Результатом разработки явилась так называемая мобильная платформа, которая была выпущена 29 мая 2013 года в вариантах для iOS и Android. Мобильная платформа «1С:Предприятия» — это набор инструментов и технологий, позволяющий создавать приложения для мобильных ОС iOS, Android, Windows Phone / 8.1 / 10, используя ту же среду разработки (Конфигуратор) и те же методики разработки, что и для обычных приложений на платформе «1С:Предприятие». В результате получаются автономные, офлайновые приложения, но с возможностью обмена информацией с внешним миром при помощи широкого спектра средств интеграции, предоставляемого платформой: Web- и HTTP-сервисы, электронная почта и т.д.
Мобильная платформа была достаточно хорошо воспринята сообществом, начали появляться различные статьи на эту тему (например, , и ). Для того, чтобы разработать полнофункциональное приложение, работающее одновременно на подавляющем большинстве мобильных устройств, теперь требовалось минимальное время и знания, принципиально не отличающиеся от знаний «обычного» прикладного разработчика на платформе «1С:Предприятие». Безусловно, такой низкий порог вхождения привлекает разработчиков, которым надо «малой кровью» обеспечить некоторой базовой функциональностью сотрудников, работающих на выезде, начальство, да и прочих мобильных сотрудников, которым требуется работа с корпоративной системой.
Начать разрабатывать мобильное приложение на платформе «1С:Предприятие» просто. В Конфигураторе нужно установить у конфигурации свойство «Назначение использования» в значение «Мобильное устройство». При этом часть прикладных объектов конфигурации станет недоступна (планы видов характеристик, планы счетов и т.д.), но станут доступны специфичные для мобильных приложений свойства (например, встроенные средства мультимедиа и геопозиционирования мобильного устройства и т.п.).
При этом отлаживать основные алгоритмы приложения (не связанные непосредственно с мобильной спецификой) можно непосредственно в Конфигураторе на компьютере разработчика. При этом участки кода, в которых происходит обращение к «мобильной» функциональности, рекомендуется обрамлять соответствующими инструкциями препроцессору, чтобы избежать ошибки при выполнении кода на персональном компьютере:
#Если МобильноеПриложениеКлиент Тогда Данные = ГеопозиционированиеСервер.ПолучитьИмяПровайдера(); #КонецЕсли
Начиная с версии мобильной платформы 8.3.7 стала доступна и отладка приложения непосредственно на мобильном устройстве (подробнее об этом ниже).
Разработка на мобильной платформе может следовать различным подходам, но можно выделить несколько основных моментов. С точки зрения построения собственно мобильного приложения, его функциональной насыщенности и роли в ИТ инфраструктуре предприятия:

  • мобильное приложение может быть составной и неотъемлемой частью существующей информационной системы предприятия. Мобильное приложение будет предоставлять интерфейс и другие возможности (включая обмен данными), «заточенные» под возможности существующей информационной системы. В этом случае мобильное приложение очень плотно связано с «обычной» информационной системой и не может эксплуатироваться в отрыве от нее.
  • мобильное приложение выполняет специфические задачи, которые практически никак не связаны с информационной системой предприятия. Существует лишь минимальный набор данных, которыми обмениваются мобильное приложение и информационная система. В этом случае, скорее всего, мобильное приложение будет выполнять обмен по некоторому стандартизированному протоколу, что делает возможным применение этого мобильного приложения в совершенно различных случаях и ситуациях.

Две вышеописанные ситуации можно считать крайними вариантами. Но это не единственные варианты разработки. Прикладной разработчик может самостоятельно выбирать возможности интеграции между мобильным приложением и той информационной системой, которая выступает бэк-офисом для него.
Мобильное приложение разрабатывается как полностью автономная конфигурация, но может разделять часть исходного текста с «родительской» конфигурацией. Кстати, «родительская» конфигурация может физически не существовать (например, если вы разрабатываете некое универсальное приложение, которое может работать с разными системами по универсальному протоколу).

Устройство мобильной платформы

Что же представляет собой мобильная платформа и что она умеет?
Справедливости ради, мобильная платформа — это всего один из компонентов всего комплекса, благодаря которому «1С:Предприятие 8» работает на мобильных устройствах. Итак, прикладной разработчик оперирует следующими компонентами:

  1. Собственно мобильная платформа — мобильная часть фреймворка «1С:Предприятие». Она бывает обычной (которая используется во время сборки приложения для публикации в магазине приложений) и мобильной платформой разработчика, которая используется (сюрприз) во время разработки мобильного приложения.
  2. Мобильная конфигурация — это конфигурация системы программ «1С:Предприятие», записанная в виде XML-файла.
  3. Комбинация мобильной платформы и мобильной конфигурации дает мобильное приложение.
  4. Сборщик мобильных приложений — специализированное прикладное решение, которое умеет сделать из мобильной платформы, конфигурации, заставок, иконок и прочих компонентов, готовый файл мобильного приложения, который можно загрузить в магазины Apple AppStore, Google Play, Windows Phone Apps / Windows Apps.

Почему все так сложно? Почему нельзя сделать на мобильном устройстве точно так, как это сделано в большой платформе? Т.е. ставить на устройство одну мобильную платформу и загружать в нее любое количество конфигураций/приложений? Это запрещают делать лицензионные ограничения на приложения, которые распространяются через магазины приложений. Например, если ваше приложение будет загружать исполняемый код (в виде скрипта) через Интернет, то оно никогда не появится в магазине приложений Apple. Следует, однако, понимать, что возможности по загрузке любой конфигурации, которые есть в мобильной платформе разработчика, не предназначены для дистрибуции мобильных приложений даже внутри одной компании, не говоря уже о дистрибуции клиентам разработчика.
После того, как мобильное приложение оказывается на целевом мобильном устройстве, возникает необходимость использовать какую-то базу данных (данные надо где-то хранить). В качестве движка базы данных мобильная платформа использует собственный движок базы данных, который портирован на мобильную платформу из платформы для персонального компьютера. Он компактен и достаточно быстр, но главное — он обеспечивает ровно такое же поведение, к которому привыкли прикладные разработчики, работая на платформе для персональных компьютеров.
Также стоит отметить, что внутри себя мобильное приложение построено по той же схеме, что и работа обычной платформы с файловым вариантом информационной базы: есть клиентская часть, есть серверная часть, есть база данных и есть клиент-серверное взаимодействие.
Собственно мобильная платформа написана как native-приложение, компилируется в двоичный код под основные процессорные архитектуры, используемые сейчас в мобильном мире: это архитектура ARM v5 и выше и x86.
Кроме того, для взаимодействия с теми или иными возможностями мобильного устройства (телефония, GPS, работа со встроенной камерой и т.п.) могут требоваться специальные разрешения. Для iOS они задаются непосредственно в процессе работы самого приложения, а для Android разрешения указываются при создании приложения. Требуемые разрешения указываются при разработке мобильного приложения и используются сборщиком мобильных приложений, но о сборщике — чуть позже.

Немного о платформе разработчика

Пока мы ведем разработку мобильного приложения – мы не связаны лицензионными ограничениями, налагаемыми на мобильные приложения, распространяемые через магазины приложений. А значит, мы можем использовать мобильную платформу 1С так же, как используем «большую» платформу на персональном компьютере – установить саму мобильную платформу на смартфон/планшет и подгружать в нее конфигурации мобильных приложений. После запуска платформа покажет нам список зарегистрированных в ней приложений:
Чтобы добавить новое приложение в платформу, нужно разместить XML-файл с его описанием на ресурсе, доступном с мобильного устройства по протоколу HTTP. Удобнее всего сделать это из Конфигуратора, через меню «Конфигурация \ Мобильное приложение \ Публиковать». При этом XML-файл с конфигурацией приложения размещается на веб-сервере на компьютере разработчика (соответственно на этом компьютере должен быть веб-сервер – IIS или Apache).
Если для приложения указать опцию «Перезапуск из конфигуратора», то приложение на мобильном устройстве будет автоматически обновляться с компьютера разработчика каждый раз, когда разработчик обновит размещенный на веб-сервере XML файл конфигурации.
При включенной опции «Отладка разрешена» возможна пошаговая отладка приложения на мобильном устройстве из Конфигуратора на компьютере разработчика (в Конфигураторе должна быть выбрана опция «Отладка по протоколу HTTP» в меню «Сервис \ Параметры»). Если в Конфигураторе поставить в коде точки останова и выбрать команду «Мобильное приложение – начать отладку», то мобильное приложение на устройстве остановится, когда исполняемый код дойдет до точки останова, и в Конфигураторе можно будет посмотреть значения переменных, стек вызовов и т.д.

Что умеет?

Итак, что умеет мобильная платформа? Достаточно много 🙂
Если не оперировать специфическими терминами «1С:Предприятия», то мобильная платформа предоставляет возможность работать с нормативно-справочной информацией, оформлять документы, описывающие какие-то внешние действия, просматривать отчеты, связываться с внешним миром с помощью интернет-сервисов и многое другое. Т.е. она предоставляет прикладному разработчику возможность написать достаточно функциональное приложение, например, программу учета домашних финансов, программу для выездной торговли и тому подобное.
Но кроме обычной функциональности, которая есть на платформе для персонального компьютера, мобильная платформа должна обеспечивать работу со специфическими возможностями, которые присущи только мобильным устройствам:

  • работа со звонками и журналом звонков;
  • работа с короткими сообщениями (SMS) и их списком;
  • контакты;
  • календари;
  • геопозиционирование (без прокладки маршрутов);
  • позволяет делать фотоснимки, а также осуществлять видео- и аудиозапись;
  • реагировать на изменение ориентации экрана;
  • работать с уведомлениями (локальными и PUSH, как напрямую, так и через специальный сервис-посредник);
  • сканировать штрих- и QR-коды с помощью камеры
  • Монетизация мобильных приложений (т.е. способ дать разработчику мобильных приложений возможности для дополнительного заработка):
    • Работа с сервисами покупок Apple In-App Purchase (для ОС iOS) и Google Play In-App Billing (для ОС Android), с помощью которых можно организовывать в мобильном приложении различного рода подписки, покупки функциональности и т.д
    • Показ рекламы в мобильных приложениях (пока поддерживаются сервисы iAd для ОС iOS и AdMob для ОС Android).
  • и т.д.

Понятно, что какие-то возможности могут быть недоступны на каждом конкретном устройстве, поэтому для определения того, что можно делать на том устройстве, на котором исполняется мобильное приложение, предусмотрены специальные методы, которые позволяют узнать, доступна на данном устройстве, например, возможность набора номера или нет. Таким образом, реализуется примерно такая схема использования: проверяем, можно использовать какую-то возможность или нельзя и если можно — используем:
Если СредстваТелефонии.ПоддерживаетсяНаборНомера() Тогда СредстваТелефонии.НабратьНомер(НомерТелефона, ВызватьСразу); КонецЕсли;
Спрятать от прикладного разработчика подробности об используемой мобильной ОС, предоставить ему унифицированные механизмы для использования мобильной функциональности – важная задача для нас. Мы считаем, что задача нами успешно решается. Различия в реализуемых механизмах или отсутствуют или сведены к минимуму. Кроме, конечно, случаев, когда функциональности в одной из ОС нет совсем.
Например, техника работа с PUSH-уведомлениями сильно отличается у Google и Apple. Мы приложили немало усилий, чтобы унифицировать механизм работы с PUSH-уведомлениями из прикладного кода. В случае мобильного приложения нам это удалось почти на 100%: один и тот же прикладной код на мобильном устройстве обрабатывает прием PUSH-уведомлений и на iOS, и на Android. И код рассылки PUSH-уведомлений в серверном приложении также выглядит одинаково. Но чтобы добиться такой унификации, нам пришлось разработать специальный сервер-прокси https://pushnotifications.1c.com/, который скрывает от разработчика разную технику работы с сервисами Apple Push Notification Service (APNS) и Google Cloud Messaging (GCM). Вся разница заключается в разных настройках непосредственно на сайте-прокси https://pushnotifications.1c.com/; для работы c APNS на сайт нужно загрузить SSL-сертификат (который Apple выдает для приложения по заявке разработчика), для работы с GCM – указать уникальный идентификатор приложения.
Очевидно, что сразу невозможно реализовать все возможности, которые вы хотите иметь в мобильном приложении. И всегда приходится искать компромисс между несколькими очень полезными вещами. И если вам чего-то не хватает — пишите нам о том, какие бизнес-задачи (ведь платформа — это в первую очередь инструмент по реализации бизнес-задач!) у вас не получается решить и какой механизм помог бы вам для этого.

Как выглядит?

Графический интерфейс мобильной платформы – отдельная тема. В 1С:Предприятии, как известно, интерфейс описывается декларативно. Это, с одной стороны, накладывает некоторые ограничения на разработку UI (например, отсутствует возможность попиксельного позиционирования), но, с другой стороны, позволяет платформе единообразно отрисовывать интерфейс на экранах разного размера, в тонком и веб-клиенте. Этого же принципа мы старались придерживаться и в мобильной платформе. Насколько хорошо нам это удалось? Попробуем разобраться.
В первых версиях мобильной платформы (до 8.3.5 включительно) графический интерфейс приложений выглядел весьма привычно для искушенных пользователей 1С; фактически он переносил знакомый по «десктопным» версиям 1С интерфейс в мобильный мир. Но с точки зрения пользователей, ранее с 1С не знакомых, интерфейс выглядел несколько архаичным.

Учтя замечания и пожелания, мы коренным образом пересмотрели свой подход к мобильному интерфейсу в версии 8.3.6. Можно сказать, что мы сделали совершенно новый мобильный интерфейс для наших приложений. Он имеет много общего с нашим интерфейсом «Такси». Модель разработки для разработчиков мобильных приложений соответствует модели разработки в «Такси». При этом мобильный интерфейс полностью соответствует принятым в мобильных приложениях подходам к дизайну и UX. Интерфейс полностью учитывает специфику мобильного мира: небольшой размер экрана (а значит, оформление графических элементов должно стать более аскетичным – без теней, градиентов), есть поддержка пальцевых жестов и т.д. Интересный факт: новый механизм платформы, отвечающий за размещение элементов в форме (layouter) оказался настолько удачным и своевременным для мобильной платформы, что был выпущен в ней раньше (в версии 8.3.6) чем в платформе для ПК (в версии 8.3.7), для которой он в первую очередь предназначался.
На картинке можно увидеть, как поменялся наш интерфейс.
Приложение «Управление небольшой фирмой» на версии мобильной платформы 8.3.5:
Оно же на версии 8.3.6:
А вот так выглядит интерфейс мобильной платформы вживую:

Сборщик — и что это за зверь?

Как уже было сказано ранее, мобильное приложение состоит из нескольких компонентов (собственно мобильная платформа, конфигурация, различные ресурсы), которые должны представлять собой единое целое для помещения приложения в магазин. Чтобы облегчить превращение компонентов в приложение, был разработан сборщик мобильных приложений. Это конфигурация (приложение), созданная на платформе «1С:Предприятие», которая хранит в своей базе данных все компоненты, необходимые для формирования мобильного приложения. Для того чтобы сборщик выполнял свою работу, нужно скачать и установить различные программные пакеты, которые нужны для его работы (Java и Android SDK и т.п.), затем указать пути к этим пакетам в настройках сборщика и задать некоторые дополнительные параметры (ключи разработчиков и т.д.).
После настройки сборщик готов к работе. В общем случае работа со сборщиком выглядит следующим образом:

  1. Загружаем версию мобильной платформы 1С, на которой будем собирать приложение
  2. Загружаем конфигурацию, из которой будем собирать мобильное приложение
  3. Создаем мобильное приложение, в котором указываем, для каких платформ (Android, iOS, Windows) надо выполнять сборку, какую конфигурацию и платформу следует использовать (в частности, указать, какой сертификат для сборки под iOS использовать в случае, если приложение работает с PUSH-уведомлениями).
  4. Выполняем «одним кликом» сборку мобильного приложения под все выбранные платформы
  5. «Другим кликом» отправляем собранные мобильные приложения в магазины приложений (если это приложение для iOS или Android). В магазины Windows Apps / Windows Phone Apps приложение нужно загружать вручную, т.к. Microsoft пока не предоставляет API для размещения приложения в магазине.

Следует отдельно отметить, что сборщик не нужен для разработки и отладки мобильного приложения. Для этого можно использовать мобильную платформу разработчика и средства Конфигуратора для передачи конфигурации на мобильное устройство. А вот для распространения мобильного приложения — нужен сборщик.

Приложения на мобильной платформе

Сама фирма «1С» выпускает на мобильной платформе ряд приложений, являющихся мобильными клиентами серверных приложений 1С (1С:Документооборот, 1С:Управление Небольшой Фирмой и т.д.). Эти приложения реализуют некоторое подмножество функциональности «обычных» клиентов. В случае мобильной версии «1С:Управление Небольшой Фирмой» функциональности достаточно для полноценного использования программы, и мы часто видели ситуацию, когда клиентам для ведения бизнеса достаточно мобильной версии приложения.
Наши партнеры используют мобильную платформу как для разработки тиражных мобильных приложений, распространяемых через магазины приложений, так и для заказных приложений, созданных по запросам конкретных клиентов. Среди тиражных приложений встречаются приложения, которые используют не 1С-ный back-end в качестве центрального хранилища данных.
Среди мобильных приложений, созданных по заказу клиентов, можно упомянуть мобильный клиент для «1С:Управления Производственным Предприятием», созданный по заказу крупного машиностроительного холдинга. Около ста сотрудников холдинга используют мобильное приложение в горячих цехах, где по соображениям техники безопасности поставить стационарные компьютеры невозможно. Встроенная камера мобильного устройства используется для чтения штрих-кодов изделий и поиска их в справочнике номенклатур, мобильное приложение позволяет понять, на каком этапе технологической цепочки находится данное изделие, отметить прохождение изделием очередной операции и т.п.

Заключение

Мы постарались очень поверхностно описать мобильную платформу, то, что она позволяет делать и почему она получилась такой, какой получилась. В данной статье практически ничего не сказано про мобильную Windows. На то есть несколько причин: во-первых, версия мобильной платформы под Windows вышла сравнительно недавно («1С:Предприятие» версии 8.3.7), во-вторых эта версия мобильной платформы не обладает какими-то существенными отличиями от реализации для других мобильных ОС. Естественно, что функциональность для ОС Windows мы будем наращивать. Равно как и наращивать функциональность мобильной платформы в целом. Так, в ближайших планах у нас – поддержка в мобильной платформе внешних компонентов; этот механизм (давно доступный в «большой» платформе), позволит разработчикам реализовать функциональность, недоступную в силу каких-либо причин в мобильной платформе.
Традиционно сильными сторонами технологической платформы «1С:Предприятие» являются легкость в освоении для разработчика и быстрота создания и модификации бизнес-приложений. Мобильная платформа 1С перенесла оба этих козыря в мобильный мир. Мобильная платформа 1С – это возможность быстро разработать приложение, работающее на трех самых массовых мобильных платформах (iOS, Android, Windows Phone / 8.1 / 10). А благодаря широкому спектру доступных платформенно-независимых средств интеграции (Web- и HTTP-сервисы и т.д.) мобильная платформа 1С — это возможность быстро создать мобильный клиент под три мобильные платформы для практически любого серверного приложения, поддерживающего любой из способов интеграции, доступных в платформе 1С (Web- и HTTP-сервисы, файловый обмен и т.д).

Add a Comment

Ваш адрес email не будет опубликован. Обязательные поля помечены *